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Introduction 
This section describes the development platforms supported by the Livescribe 
Platform SDK, as well as some issues pertaining to developers on particular 
platforms. It also contains some important notes and warnings that developers 
should keep in mind. 

Notes and Warnings 

As you start your first Livescribe smartpen application, please keep the following 
notes and restrictions in mind. 

Do Not Distribute Livescribe Binaries 

The Livescribe Platform SDK includes development tools for generating application 
resources, installing penlets to and uninstalling penlets from the smartpen. You may 
freely use these tools while developing penlets, but the Livescribe Developer License 
Agreement prohibits you from distributing these tools to your customers.  

The Livescribe online store will be the venue for sale and distribution of your penlets 
to smartpen users. Please post questions on specific binaries to the Livescribe 
Developer Forums and the Developer Team will provide answers. 

Expect Continued Support of Current API 

The Livescribe Platform exposes a Java API for developing smartpen applications. 
You can depend on the packages and classes already exposed will continue to be 
supported in the future. Upcoming releases of the SDK will contain new packages 
and classes to support additional functionality without disturbing the existing API.  
Any removal of APIs will follow standard Java deprecation procedures. 

Contents of the SDK 
The Livescribe Platform SDK includes the Livescribe Platform API, documentation, 
sample code, and a set of development tools. The official IDE for penlet development 
is Eclipse plus custom plugins for Eclipse created by Livescribe. The Livescribe API 
and all tools are immediately accessible from within Eclipse, once the plugins are 
installed. 
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Plugins and Features 

An Eclipse feature is a package of one or more Eclipse plugins. Livescribe publishes 
Eclipse features that contain the plugins you need for developing penlets and paper 
products. When you see the word feature, remember it is a specialized term in 
Eclipse and refers to a group of plugins that are installed, uninstalled, and managed 
as a group. 

Directory Structure of the SDK 

The Livescribe Platform SDK 1.5 has the following directory structure: 

• Docs 

Directory sub-tree containing documentation for the Livescribe Platform SDK.  

• EclipsePlugins 

Zip archive that contains Livescribe custom Eclipse features. Each feature 

consists of Eclipse plugins created by Livescribe to provide specialized 

functionality for penlet and paper product development.  

• EclipseFullInstall 

Zip archive that contains a full distribution of Eclipse with Livescribe custom 

Eclipse features already installed.  

• Resources 

In the audio subdirectory, you will find WAV files for the sounds that 

Livescribe uses in its own penlets.  To ensure consistency across all 

applications on the smartpen, third-party developers should include these 

audio files in their penlet projects, as needed. 

In the penletsdk directory, you will find tools to help compile penlets outside 

of Eclipse. 

Mac users will also have a PenCommService directory containing the 

installer for the smartpen communication service. 

• Samples 

Sample projects. For more samples, go to 

http://www.livescribe.com/developer. In the Developer Forums, find Sample 

Code & Docs & FAQs. 

• Platform_SDK_RelNotes_x_x_x.pdf 
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Release Notes for the current Platform SDK release. 

Setting up the IDE 
The basic environment for developing penlets and paper products consists of: 

• Eclipse 

• Eclipse plugins from Livescribe 

• JDK (Java Development Kit) 

• Ghostscript (optional) 

• Windows Users: Livescribe Smartpen Emulator (optional) 

In addition, to create background images for your paper product, you will need a 
graphics authoring tool that produces EPS files. Two excellent choices are Adobe's 
Illustrator and the open source program Inkscape. 

Hardware and Software Requirements 

Penlet and paper product development requires the following hardware and 
software: 

• PC running Windows XP SP2/SP3, Windows Vista, or Windows 7 

• Intel-based Mac running Mac OS® X 10.6 or later.  

Current restrictions for Mac development: You should not run Livescribe 

Desktop at the same time as your Mac Eclipse development environment. 

• A USB connection to a Livescribe smartpen. Alternatively, use the Livescribe 

Smartpen Emulator. 

• The Livescribe smartpen driver and smartpen communication software.  

Installing Livescribe Desktop automatically installs these for you. To develop 

penlets, you need Livescribe Desktop version 2.0 or higher and smartpen 

firmware version 2.4 or higher. Install Livescribe Desktop from: 

http://www.livescribe.com. 

• Eclipse v3.4 (Ganymede) or higher.  

• The Java Development Kit (v1.6 or higher; also known as JDK 6). 

• Ghostscript (optional). 
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• Windows Users:  Livescribe Smartpen Emulator 0.9.24 or higher (optional). 

Required for deploying penlets and their AFDs to the emulator and debugging 

them on the emulator. 

Upgrading From Earlier Versions of the SDK 

Users of Livescribe Platform SDK versions 1.x, should upgrade as follows: 

• Install the latest Livescribe plugins (features). See Updating Plugins in SDK 

1.5. 

• Mac Users: Run the PenCommService installer to get the latest version. 

Users of Livescribe Platform SDK versions 0.9.1 and below should not attempt to 
upgrade.  Starting over with a clean installation is recommended. See Installation 
Instructions (Mac and Windows). 

Two Options for Installing Livescribe Plugins 

The Livescribe Platform SDK supports installation of our Eclipse features (which are 
groups of related plugins) in two ways. You may choose the one that suits your 
development needs. 

Eclipse with Livescribe Plugins Already Added 

If you do not have Eclipse installed on your computer already, you can choose to 
quickly install Eclipse and Livescribe Eclipse features (plugins). The Livescribe 
Platform SDK includes a zip file with the full distribution of Eclipse and the Eclipse 
features. You merely decompress the zip archive on your file system and you are 
ready to start developing for the Livescribe Platform. See Installing Eclipse and 
Livescribe Plugins Together. 

Livescribe Plugins Only 

On the other hand, you may already be using Eclipse for other kinds of Java 
development. If so, you can add the capability to develop Livescribe penlets and 
paper products to your existing Eclipse distribution. The Livescribe Platform SDK 
includes a zip file that contains just Livescribe Eclipse features (plugins). In Eclipse 
terms, this zip file is an update site. Start your existing Eclipse and use the Install 
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New Software functionality to install the Livescribe plugins. See Adding Livescribe 
Plugins to Existing Eclipse. 

Mac OS X: Installation Notes 
To install the Platform SDK for Eclipse on Mac OS X, follow the instructions at 

Installation Details for Mac and Windows. Pay special attention to paragraphs flagged 

with Mac Users. The main Mac-specific notes concern the following: 

• Installing the PenComm Service. Mac users must install the PenComm Service 

manually by running 

SDKInstallDir/Resources/PenCommService/PenCommServiceInstaller.pkg,  

where SDKInstallDir is the folder to which you unzipped the Livescribe 

Platform SDK archive. This step is part of Downloading the Livescribe Platform 

SDK. 

• Installing Ghostscript. Mac users who wish to install Ghostscript as the 

rasterizer will find the following web site tailored to their needs: 

http://www.macwrite.com/critical-mass/ghostscript-mac-os-x 

Windows: Installation Notes 
To install the Livescribe Platform SDK for Eclipse on Windows, follow the instructions 

at Installation Details for Mac and Windows. Pay special attention to paragraphs 

flagged with Windows Users. The main Windows-specific notes concern the 

following: 

• Installing 32-bit JDK on 64-bit Windows. You must install the 32-bit version of 

the JDK. Accept the default directory path, which will install the JDK in 

Program Files (x86)\Java. Do not install the JDK in Windows XP Mode (if you 

have Windows 7 with that option). See Installing the JDK. 

• Installing 32-bit Ghostscript on 64-bit Windows. If you are using Ghostscript 

as your rasterizer, install the 32-bit version of Ghostscript. Accept the default 

directory path, which will install the Ghostscript in Program Files (x86)\gs. Do 

not install the JDK in Windows XP Mode (if you have Windows 7 with that 

option). See Installing Ghostscript. 
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Installation Details for Mac and Windows 
This section applies to both the Mac and Windows platforms.  Details specific to a 
platform are prefixed by Mac Users or Windows Users. 

1. Downloading the Livescribe Platform SDK. 

2. Installing the JDK. 

3. One of the following: 

• Installing Eclipse and Livescribe Plugins Together. 

• Adding Livescribe Plugins to Existing Eclipse. 

4. Installing Ghostscript. 

Downloading the Livescribe Platform SDK 

Installing the Livescribe Platform SDK to your file system consists of downloading the 
SDK zip file from the Livescribe web site and then unzipping it on your computer. In 
addition, you may choose to download the Livescribe Smartpen Emulator at this 
time. A PDF titled The Livescribe Smartpen Emulator User Guide is included in the 
Livescribe Smartpen Emulator download. 

1. Go to http://www.livescribe.com/developer. 

2. If you have not done so already, register as a Livescribe Developer by clicking 

the Register button in the lower left-hand panel. Once you have registered, 

click the Log In button in the upper right and enter your developer e-mail 

address and password. 

The first time you log in as a developer, you'll see a Download link. Click the 

link and read the Livescribe Developer License Agreement. Click the button 

entitled I Agree at the bottom the page and then click the SDK link on the 

page that follows.  

Note: During subsequent log ins with your developer account, you will 

already be on the developer welcome page.  In the right-hand column, the 

Downloads node should be opened. (If not, click the Downloads link.) Then 

use the appropriate links to download the Livescribe Platform SDK (Windows 

or Mac) and the Livescribe Smartpen Emulator (Windows).  

3. Save the download(s) to your computer. They are zip archives. 
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4. Unzip the Livescribe Platform SDK archive to a folder on your computer file 

system.  

Remember the location of the Livescribe Platform SDK. You will need it when 

you install the Livescribe plugins. 

5. Mac Users: You must install the Livescribe PenComm Service manually.  

Double-click on the installer package at 
SDKInstallDir/Resources/PenCommService/PenCommServiceInstaller.pkg 

The name SDKInstallDir is the folder to which you unzipped the archive. 

6. Windows Users:  You may also unzip the Livescribe Smartpen Emulator 

archive to a folder on your file system. The unzipped archive contains a 

manual titled The Livescribe Smartpen Emulator User Guide. Please consult it 

for information on installing and using the emulator. 

Installing the JDK 

Install JDK 6 or above. The latest version is called the Java SE Development Kit. 

1. Go to http://www.java.sun.com  

2. Click the Java SE link and then the Downloads tab.  

3. Download JDK 6 Update X (where X is the latest update number). 

Note: You must install the Java Development Kit (JDK). The Java Runtime 

(JRE) alone will not suffice. 

• 64-bit Windows Users: You must install the 32-bit JDK. Install it directly on 

your computer's file system by accepting the default directory path, which is 

X:\Program Files (x86)\Java (where X is the letter of the drive you wish to use.) 

The JDK will automatically run in Compatibility Mode. Do not install the 32-bit 

JDK in Windows XP Mode (if your version of Windows 7 has that option.) 

4. Windows Users: Verify that the JAVA_HOME system environment variable is 

set to the path of the JDK: 

On 32-bit Windows the path might be: C:\Program Files\Java\jdk1.6.0_21 

On 64-bit Windows the path might be:  
C:\ Program Files (x86)\Java\jdk1.6.0_20 
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Installing Eclipse and Livescribe Plugins Together 

Your first option is to install Eclipse 3.5.2 with the Livescribe Eclipse features (groups 
of plugins) already added. This is the simplest and fastest way to set up your Eclipse 
IDE for penlet and paper product development. One zip file contains a full 
distribution of Eclipse 3.5.2, including the pre-installed Livescribe Eclipse features. 

1. In the Livescribe Platform SDK, go to 
EclipseFullInstall\platformSDK14win32.zip 

2. Unzip the file. For instance, on Windows you might unzip it to: 
C:\eclipse3.5.2 

Eclipse does not use an installer program. Simply unzip the Eclipse 

distribution to the desired location on your file system. 

Important: Do NOT include a space in the path of your Eclipse installation, 

or in the path of your Eclipse workspace. A path with spaces in it will prevent 

you from deploying your penlets to the smartpen from Eclipse. 

3. Find the eclipse.exe file on your file system and launch Eclipse. 

Windows Users: The installation process does not create an icon in the 

Windows Start menu. You must open Windows Explorer, navigate to the 

appropriate folder, and run eclipse.exe. 

Mac Users: The installation process does not install an icon in the dock. You 

must navigate to the appropriate folder on your file system and run 

eclipse.exe. 

Adding Livescribe Plugins to Existing Eclipse 

Your second option is to add Livescribe Eclipse features (groups of plugins) to your 
existing Eclipse distribution. This option assumes that you have Eclipse already 
installed.  

Important: Do NOT include a space in the path of your Eclipse installation, or in the 

path of your Eclipse workspace. A path with spaces in it will prevent you from 

deploying your penlets to the smartpen from Eclipse. 

If you find your Eclipse has become corrupted or is not the right version, you can 
download the latest Eclipse distribution for free from http://www.eclipse.org. 
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Note: After installing Eclipse, run it at least once before trying to add any plugins. It 
is best to have an internet connection the first time you launch Eclipse, so that 
standard functionality from providers such as Eclipse.org and Mylyn can be updated 
automatically. 

1. Verify that you have a connection to the internet. Updating of plugins in 

Eclipse sometimes requires internet access. 

2. Launch Eclipse.  (Navigate to your ECLIPSE_HOME folder and launch the 

executable directly.) 

3. Select Help >Install New Software.   

On the Available Software page of the wizard, click Add. 

4. In the Add Repository dialog, click Archive. 

5. In the Repository Archive dialog, browse to  

SDKInstall\EclipsePlugins\platformSDK14updatesite.zip, where SDKInstall is 

the folder in which you unzipped the Livescribe Platform SDK archive.  Select 

the zip file and click Open. 

6. In the Add Repository dialog, click OK. 

7. On the Available Software page, a new Livescribe update site should 

automatically appear in the list box.  Select the check box for the new 

Livescribe Platform SDK update site.  Click Next. 

8. On the Install Details page, verify the Details section for each Livescribe 

features. There should be no errors or problems described in Details. Click 

Next. 

9. On the Review Licenses page, select the I accept the terms of the license 

agreement option. Then click Finish. 

The features will be installed.  

10. Click Restart Now to restart Eclipse. 

11. When Eclipse launches, you may have to select your workspace. Then click 

OK. 

12. Livescribe Penlet perspective should be showing. If not, select Window > 

Open Perspective > Penlet. Then click OK. 
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Installing Ghostscript 

Ghostscript is an open source project that includes a RIP (Raster Image Processing) 
engine that can be used as a Postscript and PDF viewer. You will need Ghostscript, or 
a similar program, in order to render images onscreen in the Paper Design 
perspective. Ghostscript is available as a free download. You will not need Ghostview  

Windows Users: Go to http://www.ghostscript.com for a list of download sites. 

Mac Users: Go to: http://www.macwrite.com/critical-mass/ghostscript-mac-os-x 

If you do not have Ghostscript installed, you will see the following error message 
when you try to view an image in the canvas: 

 

To configure the Paper Designer to work with Ghostscript: 

1. Install Ghostscript by copying the distribution files to a convenient location on 

your file system. 

2. In Eclipse, go to 

Window >Preferences >Livescribe >Postscript Rendering 
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3. In the Preferences dialog, specify values that the Paper Designer should use 

to launch the Ghostscript executable (or your favorite rasterizer).  

Windows Users: Your values might be similar to these: 

• Rasterizer executable:  
C:\Program Files\gs\gs8.64\bin\gswin32c.exe 

OR 
C:\Program Files (x86)\gs\gs8.64\bin\gswin32c.exe 

• Command line: %executable% -dUseCIEColor -dFirstPage=1 -dLastPage=1 -

dEPSCrop -dSAFER -dBATCH -dNOPAUSE -r%resolution%x%resolution% -

dNOPLATFONTS -sDEVICE=pngalpha -dBackgroundColor=16#ffffff -

dDOINTERPOLATE -dTextAlphaBits=4 -dGraphicsAlphaBits=4 -q  "-

sOutputFile=%output%" "%input%" 

• Target resolution: 1500 pixels. (For a discussion of target resolution, see 

the "Target Resolution" section in Developing Paper Products.) 

4. Windows Users: Add the Ghostscript path (or the path to your favorite 

rasterizer) to the PATH environment variable. You can do this in the System 

Variables of the System dialog.  For instance, in this case, you would add: 

C:\Program Files\gs\gs8.64\bin OR c:\Program Files (x86)\gs\gs8.64\bin  



Installing the Livescribe Platform SDK 

12 

64-bit Windows Users: The 64-bit version of Ghostscript is not currently 
supported. If you are running 64-bit Windows, you must install the 32-bit version of 
Ghostscript. Install it directly on your computer's file system by accepting the default 
directory path, which is X:\Program Files (x86)\gs (where X is the letter of the drive 
you wish to use.) Ghostscript will automatically run in Compatibility Mode. Do not 
install the 32-bit JDK in Windows XP Mode (if your version of Windows 7 has that 
option). 

Do not forget to include the location of your 32-bit Ghostscript distribution in your 
PATH environment variable. 

Updating Livescribe Plugins (Features) 
You can keep your Livescribe Eclipse plugins up-to-date by installing the latest 
update site. Livescribe uses archive update sites to update Livescribe Eclipse plugins. 
With this approach, the simplest method for acquiring updates is to download the 
latest version of the Livescribe Platform SDK from the Livescribe web site. Then 
invoke the Install New Software wizard and navigate to the update site in the 
Livescribe Platform SDK on your file system. The update site is packaged as a zip file 
and contains all the Livescribe plugins.  

Note on Eclipse Terminology: A container of related plugins is called a feature. 
Related features released by the same company are grouped in an update site. 
Archive update sites are packaged as zip files. 

When Livescribe has a new version of one or more plugins, we will create a new zip 
file (update site) and include it in the latest download of the Livescribe Platform SDK.  

Updating Plugins in SDK 1.5 

1. Mac Users: Install the latest PenCommService included in the SDK. 

2. Verify that you have a connection to the internet. Updating of features 

(plugins) in Eclipse sometimes requires internet access, even if the zip file of 

the targeted plugins is saved on your computer's file system. 

3. Launch Eclipse and select Help > Install New Software to launch the 

Install wizard. 

On the Available Software page of the wizard, click Add. 

4. In the Add Repository dialog, click Archive. 
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5. In the Repository Archive dialog, browse to  

SDKInstall\EclipsePlugins\platformSDK14updatesite.zip, where SDKInstall 

is the folder in which you unzipped the Livescribe Platform SDK archive.  

Select the zip file and click Open. 

6. In the Add Repository dialog, click OK. 

7. On the Available Software page, a new Livescribe update site should 

automatically appear in the list box. Select the check box for the new 

Livescribe Platform SDK update site. Then click Next. 

8. On the Install Details page, the Details section should state that your 

Livescribe feature(s) are already installed, so an update will of those features 

will be performed instead. Click Next. 

9. On the Review Licenses page, select the I accept the terms of the license 

agreements option. Then click Finish. 

10. Click Yes to restart Eclipse. 

11. When Eclipse launches, you may have to select your workspace. Then click 

OK. 

12. Livescribe Penlet perspective should be showing. If not, select Window > 

Open Perspective > Penlet. Then click OK. 
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Setting Eclipse Logging Preferences 

The Livescribe Eclipse plug-in uses the Apache log4j framework to enable logging at 

runtime without modifying your application binary. In Eclipse, you can control 

logging preferences using the Window > Preferences > Livescribe > Logging 

page. On this page, you can specify a custom configuration file for your logging 

preferences. You can also specify console and file appending properties. To learn 

more about this framework, and the properties you can set, go to the Apache 

website: http://logging.apache.org/log4j/. 

 

 

 


